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 5.1 Introduction to Data, Database and DBMS 
Data Data is raw, unorganized facts and figures that have no meaning by themselves. 

●​ Example: 25, “Ram”, 2081/01/15, 45000 
●​ Types: Numeric, Text (Character), Date, Logical (Yes/No). 

Database A database is an organized collection of related data stored in a structured way so 
that it can be easily accessed, managed and updated. 

●​ It is like a well-organized digital filing cabinet. 
●​ Example: Employee database, Voter list, School student record, Government service 

record. 

DBMS (Database Management System) DBMS is software that allows users to create, 
manage, update and retrieve data from a database. 

●​ It acts as an interface between the user and the database. 
●​ Popular DBMS: Microsoft Access (used in government offices), MySQL, Oracle, 

SQL Server, PostgreSQL. 
●​ Advantages: 

o​ Reduces data redundancy 
o​ Provides data security and integrity 
o​ Allows multiple users to access data simultaneously 
o​ Supports backup and recovery 

Key Difference  
Data → Raw facts  
Database → Organized collection of data  
DBMS → Software used to manage the database 
5.2 Basic Concept of Tables, Fields, Records, Relationships and Indexing 

Concept Definition Example (Employee 
Database) 

Table 
Basic building block of a database. It is a 
collection of related data organized in rows 
and columns. 

Employee Table 

Field A single column in a table that stores one type 
of information (also called Attribute). 

EmployeeID, Name, Post, 
Salary, JoinDate 

Record A single row in a table that contains complete 
information about one entity. 

One full row of an employee 
(e.g., Ram Shrestha’s details) 

Relationship Connection between two or more tables to 
avoid data repetition. 

One-to-One, One-to-Many, 
Many-to-Many 

Indexing A special structure that improves the speed of 
searching and sorting data in a table. 

Index created on EmployeeID 
or Name column 
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Types of Relationships (Very Important for Exam) 

1.​ One-to-One → One record in Table A relates to only one record in Table B (e.g., 
Employee ↔ Spouse). 

2.​ One-to-Many → One record in Table A relates to many records in Table B (e.g., 
Department ↔ Employees). 

3.​ Many-to-Many → Many records in Table A relate to many records in Table B (e.g., 
Students ↔ Subjects) – usually handled with a Junction table. 

Primary Key 

●​ A field that uniquely identifies each record (no duplicates allowed). 
●​ Example: EmployeeID, Citizenship Number. 

Foreign Key 

●​ A field in one table that refers to the Primary Key of another table. 
●​ Used to create relationships. 

Indexing 

●​ Makes searching faster (like index page in a book). 
●​ Can be created on any field but most useful on Primary Key and frequently searched 

fields. 

5.3 Introduction to Database Application 
A Database Application is a user-friendly software (DBMS) that allows creating, managing 
and using databases without writing complex code. 

●​ Popular example: Microsoft Access. 
●​ It provides ready-made tools (Tables, Queries, Forms, Reports) through a Graphical 

User Interface (GUI). 
●​ Main purpose in government offices: Maintain employee records, service records, 

inventory, voter lists, budget data, etc. 
●​ Advantages: Easy to use, visual interface, built-in security, supports relationships, 

queries, forms and reports. 
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5.3.1 Data Types 
Data types define the kind of data that can be stored in a field. 

Data Type Use Example 
Short Text Text, names, codes (max 255 characters) Name, Post, Address 
Long Text Long description or notes Remarks, Bio 
Number Numeric values for calculation Salary, Age, Quantity 
Date/Time Date and time values Join Date, DOB 
Currency Money values with decimal Salary, Budget 
Yes/No Logical (True/False) Married (Yes/No) 
AutoNumber Automatic unique ID (Primary Key) EmployeeID 
Attachment Files, photos, documents Photo, CV 
 
5.3.2 Creating, Modifying & Deleting Tables 
Creating a Table: 

●​ Create tab → Table Design (or Table). 
●​ Add Field Name and Data Type → Set Primary Key → Save (Ctrl + S). 

Modifying a Table: 

●​ Design View: Change field name, data type, field size, caption, default value. 
●​ Add/Delete fields, set validation rules. 

Deleting a Table: 

●​ Navigation Pane → Right-click table → Delete (data is permanently lost). 

5.3.3 Establishing Relationships Among Tables 
Relationships link tables to avoid data duplication. 
 Steps to Create Relationship: 

1.​ Database Tools tab → Relationships. 
2.​ Add tables to the Relationships window. 
3.​ Drag Primary Key from one table to Foreign Key of another table. 
4.​ Enforce Referential Integrity (optional but recommended). 

Types of Relationships: 

●​ One-to-One 
●​ One-to-Many (most common) 
●​ Many-to-Many (requires Junction table) 
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5.3.4 Formatting and Validating Field Data 
Formatting Field Data: 

●​ In Design View → Field Properties: 
o​ Format (e.g., Currency shows ₹ symbol) 
o​ Caption (user-friendly name) 
o​ Input Mask (e.g., phone number format) 

Validating Field Data: 

●​ Validation Rule: Limits what can be entered (e.g., >0 for salary). 
●​ Validation Text: Error message shown to user. 
●​ Required: Yes (field cannot be left blank). 
●​ Example: Validation Rule = >=10000 for salary field. 

5.3.5 Inserting, Modifying, and Deleting Data 
Inserting Data: 

●​ Open table in Datasheet View → Type directly in rows. 
●​ Or use Form for easier data entry. 

Modifying Data: 

●​ Click in the field → Edit → Press Enter or move to next field. 

Deleting Data: 

●​ Select record (click row selector) → Delete key → Confirm. 
●​ Or right-click record → Delete Record. 

5.3.6 Creating, Modifying, Deleting and Using Simple Queries / Forms / Reports 
Queries (for searching and filtering data) 

●​ Create tab → Query Design → Add tables → Drag fields → Set criteria → Run 
(exclamation mark). 

●​ Example: Query to show employees with salary > 50,000. 

Forms (for easy data entry) 

●​ Create tab → Form Wizard or Blank Form → Select fields → Finish. 
●​ Used for user-friendly input screens. 

Reports (for printing output) 

●​ Create tab → Report Wizard → Select fields → Group, sort, layout → Finish. 
●​ Can include totals, headers, footers and charts 

Modifying / Deleting: Right-click object in Navigation Pane → Design View (to modify) or 
Delete.  
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5-Mark Short Answer Questions 
Q1. (5 marks) Explain the concept of Data, Database and DBMS. 
Answer: 

●​ Data: Raw, unorganized facts and figures with no meaning (e.g., 25, “Ram”, 
2081/01/15). 

●​ Database: Organized collection of related data stored in a structured way. 
●​ DBMS: Software that creates, manages, updates and retrieves data from a database 

(e.g., Microsoft Access). 
●​ DBMS reduces data redundancy, provides security and allows multiple users to work 

simultaneously. 

Q2. (5 marks) Describe the basic concepts of Tables, Fields, Records, Relationships and 
Indexing in a database. 
Answer: 

●​ Table: Collection of related data in rows and columns. 
●​ Field: Single column that stores one type of information (e.g., Name, Salary). 
●​ Record: Single row containing complete information about one entity. 
●​ Relationship: Link between two tables (One-to-One, One-to-Many, Many-to-Many). 
●​ Indexing: Special structure that speeds up searching and sorting of data. 

Q3. (5 marks) What is a Database Application? Name any one popular database application 
used in government offices. 
Answer: A Database Application is user-friendly software (DBMS) that allows creating, 
managing and using databases through a graphical interface. 

●​ Popular example: Microsoft Access. 
●​ It provides tools for Tables, Queries, Forms and Reports. 
●​ Used in government offices for employee records, service records, inventory, voter 

lists, etc. 

Q4. (5 marks) List and explain any five important Data Types used in Microsoft Access. 
Answer: 

●​ Short Text: Text/names (max 255 characters). 
●​ Number: Numeric values for calculation. 
●​ Date/Time: Date and time values. 
●​ Currency: Money values with decimal. 
●​ AutoNumber: Automatic unique ID (used as Primary Key). 
●​ Yes/No: Logical values (True/False). 
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Q5. (5 marks) Write the steps to create, modify and delete a table in Microsoft Access. 
Answer: 

●​ Create: Create tab → Table Design → Add Field Name and Data Type → Set 
Primary Key → Save. 

●​ Modify: Open in Design View → Change field name, data type, properties. 
●​ Delete: Navigation Pane → Right-click table → Delete. 

Q6. (5 marks) Explain how to establish relationships among tables in Microsoft Access. 
Answer: 

●​ Database Tools tab → Relationships. 
●​ Add required tables. 
●​ Drag Primary Key from one table to Foreign Key of another table. 
●​ Enforce Referential Integrity (optional). 
●​ Types: One-to-One, One-to-Many, Many-to-Many. 

Q7. (5 marks) Describe how to insert, modify and delete data in a table. 
Answer: 

●​ Insert: Open table in Datasheet View → Type data in rows. 
●​ Modify: Click in the field → Edit → Press Enter. 
●​ Delete: Select record (row selector) → Press Delete key → Confirm. 

Q8. (5 marks) What are Queries, Forms and Reports? Write their uses. 
Answer: 

●​ Query: Used to search, filter and retrieve specific data. 
●​ Form: User-friendly screen for data entry and viewing. 
●​ Report: Formatted output for printing with totals, headings and charts. All are created 

from the Create tab. 

10-Mark Long Answer Questions 
Q1. (10 marks) Explain Data, Database and DBMS. Describe the basic concepts of 
Tables, Fields, Records, Relationships and Indexing. 
Answer: Data: Raw facts. Database: Organized collection of related data. DBMS: Software 
to manage database (e.g., Microsoft Access). 
Basic Concepts: 

●​ Table: Main object containing data. 
●​ Field: Column (stores one type of information). 
●​ Record: Row (complete information of one entity). 
●​ Relationship: Link between tables using Primary Key and Foreign Key. 
●​ Indexing: Improves speed of searching and sorting. 

These concepts form the foundation of any database. 
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Q2. (10 marks) What is a Database Application? Describe Data Types and the process 
of creating, modifying and deleting tables in Microsoft Access. 
Answer: A Database Application is user-friendly DBMS software that helps create and 
manage databases easily. Microsoft Access is commonly used in government offices. 
Data Types: Short Text, Number, Date/Time, Currency, AutoNumber, Yes/No, etc. 
Table Operations: 

●​ Create: Create tab → Table Design → Define fields and data types → Set Primary 
Key. 

●​ Modify: Design View → Change field properties. 
●​ Delete: Right-click table in Navigation Pane → Delete. 

These steps are essential for building a proper database structure. 
Q3. (10 marks) Explain how to establish relationships among tables. Also describe 
formatting and validating field data in Microsoft Access. 
Answer: Establishing Relationships: 

●​ Database Tools → Relationships → Add tables → Drag Primary Key to Foreign Key 
→ Enforce Referential Integrity. 

Formatting and Validating Field Data: 

●​ In Design View → Field Properties: 
o​ Format, Caption, Input Mask. 
o​ Validation Rule (e.g., >=10000) and Validation Text. 
o​ Required = Yes. 

These features maintain data accuracy and consistency. 
Q4. (10 marks) Describe the process of inserting, modifying and deleting data. Also explain 
how to create and use simple Queries, Forms and Reports in Microsoft Access. 
Answer: Data Operations: 

●​ Insert: Datasheet View → Type data. 
●​ Modify: Click field → Edit. 
●​ Delete: Select record → Delete key. 

 
Queries, Forms and Reports: 

●​ Query: Create → Query Design → Add tables → Set criteria → Run. 
●​ Form: Create → Form Wizard → Select fields. 
●​ Report: Create → Report Wizard → Add grouping and totals. 

These tools make data entry, searching and printing easy and user-friendly. 
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Q5. (10 marks) Explain the complete process of creating a simple database in Microsoft 
Access, including tables, relationships, data entry and output (Queries, Forms, Reports). 
Answer: 

1.​ Create new database file. 
2.​ Create Tables in Design View → Define fields and data types. 
3.​ Establish Relationships (Database Tools → Relationships). 
4.​ Enter data in Datasheet View or Form. 
5.​ Create Query for searching, Form for input, Report for printing. 

This complete process is used in government offices for maintaining official records. 
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