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4.1 Concept of Electronic Spreadsheet 
An Electronic Spreadsheet is a computer application used to organise, calculate, analyse and 
present numerical data in rows and columns. 

●​ It replaces traditional paper ledgers and calculators. 
●​ Popular software: Microsoft Excel (most commonly used), Google Sheets, 

LibreOffice Calc. 
●​ Main uses in government offices: Budget preparation, salary sheet, attendance 

register, financial reports, data analysis and charts. 
●​ Advantages: Automatic calculations, easy editing, formulas & functions, large data 

handling, printing and charting. 

4.2 Organization of Electronic Spreadsheet Application 
The structure of an Electronic Spreadsheet (MS Excel) is as follows: 

Term Description Example 
Cell Intersection of a row and a column A1, B5, C10 

Row Horizontal line numbered (1, 2, 3 …) Row 1 to 
1,048,576 

Column Vertical line labelled with letters (A, B, C …) Column A to XFD 
Worksheet Single page/sheet inside a workbook Sheet1, Sheet2 
Workbook Complete Excel file containing one or more worksheets Book1.xlsx 

Workspace Collection of multiple workbooks opened together (rarely 
used now) - 

●​ Active Cell: The cell that is currently selected (thick border). 
●​ Cell Address: Combination of column letter and row number (e.g., D8). 
●​ Cell Range: Group of cells (e.g., A1:A10 or B2:D5). 

4.3 Creating, Opening, Saving, Page Setting, Previewing and Printing Workbook; 
Changing Default Options 
Creating a New Workbook: 

●​ File → New → Blank Workbook (or Ctrl + N). 

Saving a Workbook: 

●​ File → Save (Ctrl + S) → Choose location → Name → Save as .xlsx. 

Opening an Existing Workbook: 

●​ File → Open (Ctrl + O) → Select file. 

Page Setting: 

●​ Page Layout tab → Page Setup group: 
o​ Margins, Orientation (Portrait/Landscape), Paper Size (A4), Scaling. 
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Previewing and Printing: 

●​ File → Print (Ctrl + P) → Print Preview → Select printer → Print. 

Changing Default Options: 

●​ File → Options → General: Change default font (e.g., Preeti or Kalimati for 
Devanagari), font size, number of sheets, etc. 

●​ File → Options → Save: Set default file format and location. 

4.4 Elements of Electronic Spreadsheet Environment 
The main parts of the MS Excel screen are: 

Element Location Function 

Menu / Ribbon Top of the screen Tabs: Home, Insert, Page Layout, Formulas, 
Data, Review, View 

Toolbars / Quick 
Access Toolbar 

Above Ribbon 
(customizable) Save, Undo, Redo, etc. 

Formula Bar Below Ribbon Displays and edits formula/content of active 
cell 

Status Bar Bottom of the screen Shows sum, count, average, zoom level, 
view mode 

Rulers Horizontal & Vertical Helps set margins and column width (visible 
in Page Layout view) 

Scrollbars Right and bottom Move through large worksheets 
Name Box Left of Formula Bar Shows active cell address 
Other elements: Sheet tabs at the bottom, Row & Column headers. 
4.5 Editing, Copying, Moving, Deleting Cell Contents; Formatting Cells; Formatting 
Rows, Columns and Sheets 
Editing Cell Contents: 

●​ Double-click the cell or press F2 → Type → Enter. 

Copying, Moving and Deleting: 

●​ Select cell/range → Ctrl + C (Copy) / Ctrl + X (Cut) / Delete. 
●​ Paste: Ctrl + V. 
●​ Drag and Drop: For moving (hold Shift for copy). 

Formatting Cells (Home tab → Cells group → Format): 

●​ Font: Style, size, colour, bold, italic, underline. 
●​ Border: Outline, inside, thick, coloured borders. 
●​ Pattern / Fill: Background colour and fill effects. 
●​ Alignment: Horizontal (Left, Center, Right, Justify), Vertical, Wrap Text, Merge & 

Center. 
●​ Number: General, Number, Currency, Date, Percentage, Custom. 
●​ Protection: Lock cells (used with Sheet Protection). 
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Formatting Rows, Columns and Sheets: 

●​ Row Height / Column Width: Home → Format → Row Height / Column Width (or 
drag borders). 

●​ Hide/Unhide: Right-click row/column number → Hide. 
●​ Insert/Delete: Right-click → Insert / Delete. 
●​ Sheet: Right-click sheet tab → Insert, Delete, Rename, Move/Copy, Protect Sheet. 

4.6 Using Formula – Relative Cell and Absolute Cell Reference 
A formula is an expression that performs calculation on cell values. Every formula in Excel 
starts with = sign. 
Types of Cell Reference: 

Type Symbol Behaviour when copied Example Use 
Relative No $ Changes automatically =A1+B1 Normal calculation 
Absolute $A$1 Does not change =$A$1+$B$1 Fixed cell (e.g., tax rate) 
Mixed $A1 or A$1 One part fixed =$A1+B$1 Partial fixed reference 
How to toggle reference: Select cell reference inside formula → Press F4 key repeatedly. 
Example: 

●​ Relative: In cell C1 write =A1+B1 → Copy to C2 → becomes =A2+B2 
●​ Absolute: =$A$1+$B$1 → remains same when copied. 

4.7 Using Basic Functions 
Functions are pre-written formulas. They start with = followed by function name and 
arguments in brackets. 
Most Important Basic Functions: 

Function Syntax Use Example 
SUM =SUM(range) Total of numbers =SUM(A1:A10) 
AVERAGE =AVERAGE(range) Average value =AVERAGE(B1:B20) 

MAX / MIN =MAX(range) / =MIN(range) Highest / Lowest 
value =MAX(C1:C50) 

COUNT =COUNT(range) Count of numeric 
cells =COUNT(D1:D100) 

COUNTA =COUNTA(range) Count of all 
non-empty cells =COUNTA(A1:A100) 

IF =IF(condition, value_if_true, 
value_if_false) Logical test =IF(A1>40,"Pass","Fail") 

Note: Functions can be combined (e.g., =SUMIF, =COUNTIF) and are found under 
Formulas tab → Function Library. 
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4.8 Generating Series; Sorting and Filtering Data; Summarizing Data with Sub Totals 
Generating Series: 

●​ Type first two values (e.g., 1, 2) → Select both → Drag Fill Handle (small square at 
bottom-right of cell). 

●​ Or Data tab → Fill → Series (Linear, Growth, Date, etc.). 

Sorting Data: 

●​ Select data → Data tab → Sort → Choose column → Ascending / Descending. 

Filtering Data: 

●​ Select data → Data tab → Filter (drop-down arrows appear). 
●​ Click arrow → Apply criteria (text, number, colour filter). 

Summarizing with Sub Totals: 

●​ First sort the data by the column you want to subtotal. 
●​ Data tab → Subtotal → Choose “At each change in” column → Function (Sum, 

Count, Average) → OK. 
●​ To remove: Data → Subtotal → Remove All. 

4.9 Creating Charts 
Charts present data visually. 
Steps to Create Chart: 

1.​ Select data range. 
2.​ Insert tab → Charts group → Choose chart type: 

o​ Column / Bar 
o​ Pie 
o​ Line 
o​ Area 
o​ Scatter 

3.​ Chart appears → Use Chart Design and Format tabs to change style, title, legend, axis 
labels, colours. 

4.​ Move chart: Click and drag to new location or to new sheet. 

4.10 Inserting Header and Footer 

●​ Insert tab → Text group → Header & Footer. 
●​ Header appears at top, Footer at bottom. 
●​ Options: Page number, Date, File name, Custom text, Picture. 
●​ Switch between Header/Footer using the buttons in Header & Footer tab. 
●​ Used mainly in Page Layout view for printing. 
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4.11 Spell Checking 

●​ Review tab → Spelling (or press F7). 
●​ Red underline = spelling mistake. 
●​ Right-click underlined word → Choose correct suggestion. 
●​ Options: Ignore, Ignore All, Add to Dictionary. 
●​ Also checks grammar in newer versions. 

4.12 Importing Data from and Exporting into Other Formats 
Importing: 

●​ Data tab → Get Data → From File → From Text/CSV 
●​ Or From Web, From Access, From Excel. 
●​ Text Import Wizard helps set delimiter (comma, tab, etc.). 

Exporting: 

●​ File → Save As → Choose format: 
o​ PDF (*.pdf) 
o​ CSV (Comma delimited) 
o​ Text (Tab delimited) 
o​ Web Page 
o​ Older Excel format (.xls) 

4.13 Familiarity with Devanagari Fonts 

●​ Devanagari fonts used for Nepali language: Preeti, Kalimati, Mangal, Sagarmatha. 
●​ Change font: Home tab → Font → Select Preeti / Kalimati (size 11–14). 
●​ Change default font: File → Options → General → Default font → Preeti. 
●​ Keyboard: Windows + Space to switch between English and Nepali layout. 
●​ Important for government salary sheets, reports and official data entry. 

 

5-Mark Short Answer Questions 
Q1. (5 marks) Explain the concept of Electronic Spreadsheet and its uses in government 
offices. 
Answer: Electronic Spreadsheet is a computer application used to organise, calculate, 
analyse and present numerical data in rows and columns. 

●​ Popular software: Microsoft Excel. 
●​ Main uses: Budget sheet, salary register, attendance, financial reports. 
●​ Advantages: Automatic calculation, easy editing, formulas, charts and large data 

handling. 
●​ It replaces traditional paper ledgers and calculators. 
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Q2. (5 marks) Describe the organization of Electronic Spreadsheet (Cells, Rows, 
Columns, Worksheet, Workbook). 
Answer: 

●​ Cell: Intersection of row and column (e.g., A1). 
●​ Row: Horizontal line (numbered 1, 2, 3…). 
●​ Column: Vertical line (lettered A, B, C…). 
●​ Worksheet: Single page/sheet. 
●​ Workbook: Complete Excel file containing one or more worksheets. 
●​ Active cell has thick border; cell address is column letter + row number. 

Q3. (5 marks) Write the steps to create, save, open and print a workbook in MS Excel. 
Answer: 

●​ Create: File → New → Blank Workbook (Ctrl + N). 
●​ Save: File → Save (Ctrl + S) → Choose location → Name → .xlsx. 
●​ Open: File → Open (Ctrl + O). 
●​ Print: File → Print (Ctrl + P) → Set Page Layout → Print Preview → Print. 

Q4. (5 marks) Describe the main elements of Electronic Spreadsheet Environment. 
Answer: 

●​ Ribbon/Menu: Top tabs (Home, Insert, Formulas, Data, etc.). 
●​ Formula Bar: Shows and edits content/formula of active cell. 
●​ Status Bar: Shows sum, average, count, zoom level. 
●​ Rulers & Scrollbars: For margins and navigation. 
●​ Name Box: Displays active cell address. 

 
 
Q5. (5 marks) Explain Relative and Absolute Cell Reference with examples. 
Answer: 

●​ Relative Reference: Changes when copied (e.g., =A1+B1 becomes =A2+B2). 
●​ Absolute Reference: Does not change (use $ sign, e.g., =$A$1+$B$1). 
●​ Toggle with F4 key. 
●​ Used in formulas for fixed values like tax rate or percentage. 

Q6. (5 marks) Write any five basic functions of MS Excel with examples. 
Answer: 

●​ SUM: =SUM(A1:A10) → Total 
●​ AVERAGE: =AVERAGE(B1:B20) → Average value 
●​ MAX / MIN: =MAX(C1:C50) / =MIN(C1:C50) 
●​ IF: =IF(A1>40,“Pass”,“Fail”) 
●​ COUNT: =COUNT(D1:D100) → Count of numbers 
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Q7. (5 marks) Explain how to create charts, insert Header & Footer and perform Spell 
Checking in Excel. 
Answer: 

●​ Charts: Select data → Insert → Chart (Column, Pie, Line). 
●​ Header & Footer: Insert → Header & Footer → Add page number, date, file name. 
●​ Spell Checking: Review → Spelling (F7) → Correct red underlined words. 

Q8. (5 marks) Describe how to generate series, sort, filter data and use Sub Totals in 
Excel. 
Answer: 

●​ Series: Type first two values → Drag Fill Handle. 
●​ Sort: Data → Sort → Choose column. 
●​ Filter: Data → Filter → Apply criteria. 
●​ Sub Totals: First sort data → Data → Subtotal → Choose column and function. 

10-Mark Long Answer Questions 
Q1. (10 marks) Explain the concept of Electronic Spreadsheet. Describe its organization 
and the main elements of its environment. 
Answer: Electronic Spreadsheet is software used to organise and calculate numerical data. 
Organization: 

●​ Cell, Row, Column, Worksheet, Workbook. 

Environment Elements: 

●​ Ribbon with different tabs 
●​ Formula Bar 
●​ Status Bar 
●​ Rulers, Scrollbars and Name Box 

These features make data entry, calculation and presentation very easy and efficient. 
Q2. (10 marks) Describe the process of creating, saving, opening, page setting and 
printing a workbook. Also explain how to change default options. 
Answer:  
Creating: Ctrl + N → Blank Workbook.  
Saving: Ctrl + S (.xlsx).  
Opening: Ctrl + O.  
Page Setting: Page Layout → Margins, Orientation, Paper Size (A4).  
Printing: Ctrl + P → Print Preview. 
Default Options: File → Options → General → Change default font (e.g., Preeti), number of 
sheets, etc. This process is very important for official government reports. 
Q3. (10 marks) Explain editing, copying, moving and formatting features of cells, rows, 
columns and sheets in MS Excel. 
Answer: Editing: Double-click or press F2. Copy/Move/Delete: Ctrl + C, Ctrl + X, Delete. 
Formatting Cells: 

●​ Font, Border, Fill colour, Alignment, Number format, Protection. 
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Rows & Columns: 

●​ Change height/width, Insert/Delete, Hide/Unhide. 

Sheets: Rename, Move/Copy, Protect Sheet. These features help in making professional and 
readable data sheets. 
 
 
 
Q4. (10 marks) What are formulas and functions in Excel? Explain Relative and 
Absolute Cell Reference with examples. Also describe any five basic functions. 
Answer: Formulas start with “=” sign. 
Cell Reference: 

●​ Relative: Changes when copied. 
●​ Absolute: Fixed with $ sign (press F4). 

Basic Functions: SUM, AVERAGE, MAX, MIN, IF, COUNT, COUNTA. 
These are used for automatic calculations in salary sheets, budget and reports. 
Q5. (10 marks) Describe how to generate series, sort, filter, create charts, insert Header 
& Footer and use Import/Export features in MS Excel. 
Answer: 

●​ Series: Drag Fill Handle or Data → Fill → Series. 
●​ Sort & Filter: Data tab. 
●​ Charts: Insert → Choose type (Column, Pie, Line). 
●​ Header & Footer: Insert tab. 
●​ Import/Export: Data → Get Data or Save As (PDF, CSV). 

These features are essential for data analysis and official reporting. 
Q6. (10 marks) Explain the importance of Devanagari fonts and security/proofing tools 
(Spell Checking, Protection) in Electronic Spreadsheet for government use. 
Answer: 

●​ Devanagari Fonts: Preeti, Kalimati → Used for Nepali data entry (set as default in 
Options). 

●​ Spell Checking: Review → Spelling (F7). 
●​ Protection: Lock cells and protect sheet to prevent unauthorised changes. 

These tools ensure accuracy, Nepali language support and data security in official documents. 
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